Fehler bei der Installation des SCSM 2012 SP1 Authoring Tool

Letztens hatte ich einen Fehler bei der Installation des Authoring Tool. Diese Fehler hat sich binnen wenigen Tagen bei mehreren Kunden wiederholt.

Ich hab in den letzten Wochen einige Upgrades auf System Center Service Manager 2012 SP1 gemacht und musst somit auch das Authorng Tool updaten, dabei bekam ich folgenden Fehler.

Capture

Finalize
An error occurred while executing a custom action:RollbackCleanup

Danach hab ich mal das Setup Log durchsucht und folgende Passage gefunden

MSI (s) (A4:E8) [16:07:15:301]: Note: 1: 1402 2: UNKNOWN\Installer\Products\9F32C4B9649D4F941ABA8129A95199C2 3: 2
MSI (s) (A4:E8) [16:07:15:301]: Note: 1: 1402 2: UNKNOWN\Installer\Products\9F32C4B9649D4F941ABA8129A95199C2 3: 2
MSI (s) (A4:E8) [16:07:15:305]: Executing op: UpgradeCodePublish(UpgradeCode={CA2BF227-625E-480C-9A4B-1B949A3F52F7})
MSI (s) (A4:E8) [16:07:15:306]: Executing op: SourceListPublish(,,,,NumberOfDisks=1)
MSI (s) (A4:E8) [16:07:15:306]: Note: 1: 1402 2: UNKNOWN\Installer\Products\9F32C4B9649D4F941ABA8129A95199C2\SourceList 3: 2
MSI (s) (A4:E8) [16:07:15:308]: Executing op: ProductPublishClient(,,)
MSI (s) (A4:E8) [16:07:15:308]: Executing op: SourceListRegisterLastUsed(SourceProduct={9B4C23F9-D946-49F4-A1AB-18929A15992C},LastUsedSource=C:\Users\administrator.SABTOURS\Desktop\authoring\Setup\)
MSI (s) (A4:E8) [16:07:15:308]: Entering CMsiConfigurationManager::SetLastUsedSource.
MSI (s) (A4:E8) [16:07:15:309]: Specifed source is already in a list.
MSI (s) (A4:E8) [16:07:15:309]: User policy value ‚SearchOrder‘ is ’nmu‘
MSI (s) (A4:E8) [16:07:15:309]: Adding new sources is allowed.
MSI (s) (A4:E8) [16:07:15:309]: Set LastUsedSource to: C:\Users\administrator.SABTOURS\Desktop\authoring\Setup\.
MSI (s) (A4:E8) [16:07:15:309]: Set LastUsedType to: n.
MSI (s) (A4:E8) [16:07:15:309]: Set LastUsedIndex to: 1.
MSI (s) (A4:E8) [16:07:15:309]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=105946253)
MSI (s) (A4:E8) [16:07:15:316]: User policy value ‚DisableRollback‘ is 0
MSI (s) (A4:E8) [16:07:15:316]: Machine policy value ‚DisableRollback‘ is 0
MSI (s) (A4:68) [16:07:15:351]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI41EB.tmp, Entrypoint: SetupAuthoringTool
CAPACK: Extracting custom action to temporary directory: C:\Windows\Installer\MSI41EB.tmp-\
CAPACK: Binding to CLR version v2.0.50727
Calling custom action CAAuthoring!Microsoft.SystemCenter.ServiceManager.Setup.CAAuthoring.SetupAuthoringTool
Authoring Tool: „C:\Program Files (x86)\Microsoft System Center 2012\Service Manager Authoring\SMAuthoring.exe“
RunCommand: Executing:“C:\Program Files (x86)\Microsoft System Center 2012\Service Manager Authoring\SMAuthoring.exe“ /setup
RunCommand: ‚“C:\Program Files (x86)\Microsoft System Center 2012\Service Manager Authoring\SMAuthoring.exe“‚ failed with Exit code -1073741515
RunCommand: Error:
SetupAuthoringTool: **Error**: Failed to setup Authoring Tool
MSI (s) (A4:68) [16:07:17:959]: NOTE: custom action _SetupAuthoringTool unexpectedly closed the hInstall handle (type MSIHANDLE) provided to it. The custom action should be fixed to not close that handle.
CustomAction _SetupAuthoringTool returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (A4:E8) [16:07:17:964]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1111785660,LangId=1033,Platform=0,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
MSI (s) (A4:E8) [16:07:17:964]: Executing op: DialogInfo(Type=0,Argument=1033)

Nach einiger Suche und einem Beitrag im Technet Forum, habe ich die Lösung gefunden.

Das Packet “Microsoft Visual C++ 2010 Redistributable Package (x86)” muss installiert werden, danach läuft die Installation sauber durch.

Download: http://www.microsoft.com/de-de/download/details.aspx?id=5555

Michael Seidl

Probleme mit SP1 für Windows 7 und Server 2008 R2

Letzte Woche hatte ich ja bekanntlich bei einem Kunden das Problem, das nach der Installation des SP1 und einen Neustart der Fehler C0000034 erscheint, und sich der PC nicht mehr starten lies. Mehr zum Problem und einer Lösung hier – http://www.techguy.at/2011/03/10/windows-7-sp1-fehler-c0000034-beim-updatevorgang-282-von-118412-behoben
Nachdem nun einige Tage vergangen sind, fasse ich hier nun die Geschehnisse einmal zusammen, was es zu diesem Thema neues gibt. Welche anderen Lösungen existieren, und was Microsoft dazu sagt.

Windows 7 SP1, Fehler C0000034 beim Updatevorgang 282 von 118412– behoben

Hatte heute einen überraschenden Einsatz bei einem Neukunden, der gestern auf 3 Windows 7 PCs, beim herunterfahren das Servicepack 1 für Windows 7 installierte. Heute früh beim einschalten der betroffenen Rechner kam dann der Schreck.

Fehler C0000034 beim Updatevorgang 282 von 118412 (_00000…)

Wobei hier die Zahlen 282 und 118412 variieren können. So etwas gegoogelt, habe ich einen Lösung gefunden, bei der, der Registry-Schlüssel “SetupExecute” im Verzeichnis “HKLM\BaseSystem\CurrentControlSet\Control\Session Manager\” neu erstellt wird, leider hatte dies keinen Erfolg. Die Lösung gibt es hier.

(Read more…)